Pré-requis et hébergement

Pour installer Galette, vous aurez besoin que ces prérequis soient respectés:

  • un serveur web (comme Apache),
  • PHP 7.1 ou plus récent,
    • le module PHP gd,
    • le module PHP PDO et mysql ou postrgesql pour PDO,
    • le module PHP curl,
    • le module PHP intl,
    • le support SSL,
    • le module PHP tidy (optionnel, mais recommandé),
    • le module PHP gettext (optionnel).
  • Un serveur de base de données, MariaDB (ou MySQL) 5.5 minimum, ou PostgreSQL 9.1 minimum.

Galette est régulièrement testé avec des versions récentes de ces composants. Si vous rencontrez des problèmes avec une version récente, n’hésitez pas à nous le faire savoir ;)

Galette est incompatible avec les hébergements suivants :

  • Free,
  • Olympe Networks.